Unscheduled Marketplace Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Nov 04, 2019 - 21:06 PST
Investigating
We are currently undergoing unscheduled Second Life Marketplace maintenance. Transactions may not be updating, deliveries may be delayed and all other Marketplace information may not be updating in a timely fashion. We ask that you please refrain from making Marketplace purchases until this maintenance is complete. Please check this post for updates.
Posted Nov 04, 2019 - 19:15 PST
This incident affected: Websites (marketplace.secondlife.com) and Second Life Services (Marketplace Purchases).