Unscheduled Maintenance On my.secondlife.com
Incident Report for Second Life
Resolved
We have completed the unscheduled maintenance for my.secondlife.com.
Posted 2 months ago. Apr 11, 2019 - 19:03 PDT
Update
We are continuing to investigate this issue.
Posted 2 months ago. Apr 11, 2019 - 17:49 PDT
Investigating
We are currently investigating an issue with my.secondlife.com. Access to my.secondlife.com or updates to profiles may be impacted during this time. Please monitor this blog for updates.

Thank you for your patience during this time.
Posted 2 months ago. Apr 11, 2019 - 17:48 PDT
This incident affected: Websites (my.secondlife.com).