Unscheduled Log In Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 13 days ago. Oct 05, 2018 - 12:05 PDT
Investigating
We are currently aware of and investigating an issue affecting viewer log in. Some Residents may experience trouble logging in and staying logged in. Please continue to check this blog for updates.

We appreciate your patience during this time.
Posted 13 days ago. Oct 05, 2018 - 11:28 PDT
This incident affected: Second Life Services (Logins).