Feedback Portal Login Outage

Incident Report for Second Life

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 09:14 PDT

Investigating

We are receiving reports of login issues on our feedback portal (https://feedback.secondlife.com/) and are currently investigating the cause of this issue. We hope to have access restored to all users soon. In the meantime, please refer to this status page for updates as our investigation continues.
Posted Sep 01, 2026 - 08:51 PDT
This incident affected: Websites (feedback.secondlife.com).