Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
The billing maintenance has been completed.
Posted 5 months ago. Mar 21, 2019 - 14:39 PDT
Investigating
We are currently performing unscheduled billing maintenance. While this maintenance is in progress, some of our international users may experience failed transactions or be unable to add credit cards as payment methods. Please watch this blog for further updates.
Posted 5 months ago. Mar 21, 2019 - 14:00 PDT