Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been completed.
Posted 3 months ago. Dec 17, 2018 - 06:22 PST
Investigating
We are currently performing unscheduled maintenance on our billing system. Some users may be unable to enter new credit cards while this maintenance is in progress. Existing cards and other forms of payment should not be affected. Please watch this blog for updates.
Posted 3 months ago. Dec 16, 2018 - 13:54 PST