Extended Inventory Service Maintenance

Scheduled for Feb 25, 15:00 - 19:00 PST

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 25, 2026 - 07:39 PST

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 25, 2026 - 06:42 PST

Scheduled

We are continuing to complete inventory maintenance which began on Tuesday, February 25th at 3:00 PM Pacific Time. Please be advised that logins, in-world inventory access, marketplace purchases, etc. may be temporarily impacted during the maintenance window. This is an extension of our earlier scheduled maintenance, and we apologize for the early automated resolution of the maintenance notification.
Posted Feb 25, 2026 - 06:37 PST
This scheduled maintenance affects: Second Life Services (Logins, Marketplace Purchases) and Inworld Services (L$ Transactions, Rezzing, Inventory).