Offline IM Issues
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Dec 17, 2020 - 10:14 PST
Investigating
We are currently investigating an issue with some accounts not receiving emails as expected. Please keep an eye on this blog for updates.
Posted Dec 16, 2020 - 11:48 PST