Unscheduled Marketplace Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Feb 07, 2020 - 14:18 PST
Investigating
We are currently performing maintenance to the Marketplace. During this maintenance, residents may be unable to access the Marketplace. Please watch this blog for updates.
Posted Feb 07, 2020 - 13:54 PST
This incident affected: Websites (marketplace.secondlife.com) and Second Life Services (Marketplace Purchases).