Issues With The Land Store (land.secondlife.com)
Incident Report for Second Life
Resolved
We have resolved the Land Store issue.
Posted 5 months ago. Jul 03, 2018 - 07:59 PDT
Investigating
We are currently investigating an issue with the Land Store (land.secondlife.com). Please see this post for more information and updates:

https://community.secondlife.com/forums/topic/424445-private-estate-prices-drop-but-the-land-store-is-having-issues/

We thank you for your patience during this time.
Posted 5 months ago. Jul 02, 2018 - 16:41 PDT