Billing phone support unavailable
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 10 days ago. Apr 13, 2018 - 20:29 PDT
Monitoring
Billing phone support will be unavailable from 12:00 PM PDT to 1:00 PM PDT, Friday, April 13th, 2018. Ticket submissions, and concierge phone and chat support will still be available.
Posted 10 days ago. Apr 13, 2018 - 12:35 PDT
This incident affected: External Support (Phone Support).