Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Oct 14, 2020 - 10:56 PDT
Investigating
We are aware of an issues currently which may cause some payments to not process. At this time, Residents may be unable to use the cashier or to make purchases, and some purchases may take longer than normal to process. Please watch this blog for updates.
Posted Oct 14, 2020 - 10:47 PDT
This incident affected: Websites (marketplace.secondlife.com) and Second Life Services (LindeX Purchases, Marketplace Purchases, Process Credits).