Username Change Maintenance
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Oct 06, 2021 - 12:27 PDT
Update
While the maintenance for name changes is underway, Residents who wish to change their username may contact support for assistance. Please submit a support ticket at https://support.secondlife.com/create-case/ using the type Technical Questions > Avatar Issues. We appreciate your patience at this time!
Posted Oct 05, 2021 - 09:03 PDT
Identified
Username changes will be undergoing maintenance, and may be down for an extended period.

Please watch this blog for additional information.
Posted Oct 04, 2021 - 12:02 PDT