Unscheduled Support Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been completed.
Posted 2 months ago. Jun 02, 2018 - 12:49 PDT
Investigating
We are currently undergoing unscheduled support services maintenance. Live Chat support and Support Ticket submission may not be available until the maintenance is complete. Phone support is still available where applicable.
Posted 2 months ago. Jun 02, 2018 - 06:47 PDT
This incident affected: External Support (Chat Support, Case Support).