Weekly Premium Stipends Delayed
Incident Report for Second Life
Resolved
This week's stipends have been successfully distributed. For any residents that did not receive today's stipend please contact Support.
Posted 6 months ago. Mar 27, 2018 - 11:45 PDT
Identified
We are aware that some residents Weekly Premium Stipends have been delayed. We are in the process of getting those out. We will update this blog when that has been completed. Thank you for your patience!
Posted 6 months ago. Mar 27, 2018 - 07:02 PDT