Unscheduled Second Life maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been resolved.
Posted 7 months ago. Feb 26, 2018 - 14:47 PST
Investigating
We are aware that there may be an issue with Second Life logins at this time. We are actively investigating this issue, and will provide updates via this blog. Thank you for your patience as we work to resolve this.
Posted 7 months ago. Feb 26, 2018 - 13:29 PST
This incident affected: Websites (secondlife.com) and Second Life Services (Logins, LindeX Purchases, Marketplace Purchases, Process Credits).