Increased Ticket Volumes
Incident Report for Second Life
Resolved
Thank you for your patience! We're happy to report that wait times for most of our Support ticket types have improved to the point that we're marking this report as resolved. However, our Support department is still experiencing a heightened level of interest in Second Life, which may slightly increase wait times for some specialist Support tickets. We're very sorry for the inconvenience.
Posted Jul 31, 2020 - 11:14 PDT
Identified
We are currently experiencing higher than normal ticket volumes. We apologize for any delay you may experience and our support teams are currently working all tickets in the order that they are recieved. We appreciate your patience.
Posted May 04, 2020 - 13:59 PDT
This incident affected: External Support (Case Support).