Support.secondlife.com partial outage
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted Mar 14, 2022 - 10:17 PDT
Investigating
We are experiencing intermittent issues with the support.secondlife.com website and Residents logging into their accounts. Guest tickets can still be submitted at this time.

Please watch this blog for further updates.
Posted Mar 14, 2022 - 08:31 PDT
This incident affected: Websites (support.secondlife.com).