Billing Issues
Incident Report for Second Life
Resolved
The MasterCard transactions issue has been resolved. If you continue to experience any issues using the MasterCard payment method please contact Support.
Posted 17 days ago. Jul 05, 2018 - 12:02 PDT
Update
Thank you for your continued patience. This issue is still under investigation, and we will provide updates here as we have them.
Posted 20 days ago. Jul 02, 2018 - 07:46 PDT
Update
We are continuing to investigate this issue. Thank you so much for your continued patience.
Posted 23 days ago. Jun 29, 2018 - 09:22 PDT
Investigating
We are currently investigating an issue that may still cause some Mastercard transactions to fail. This may also prevent Mastercards from being added as payment methods. Please monitor this blog for more updates as they become available.
Posted about 1 month ago. Jun 22, 2018 - 10:52 PDT