Login Trouble Surrounding Europe
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted May 23, 2020 - 15:03 PDT
Investigating
We are aware of connectivity issues with residents unable to login from the UK region. We are monitoring the issue and will update this blog as it develops.
Posted May 23, 2020 - 13:10 PDT