Weekly Premium Stipends Delayed
Incident Report for Second Life
Resolved
All stipends have been successfully distributed. For any residents that did not receive today's stipend please contact Support.
Posted 6 months ago. May 01, 2018 - 09:35 PDT
Investigating
We are aware that some residents Weekly Premium Stipends have been delayed. We are in the process of getting those out. We will update this blog when that has been completed. Thank you for your patience!
Posted 6 months ago. May 01, 2018 - 06:04 PDT
This incident affected: Inworld Services (L$ Transactions).