Weekly Stipends Delayed
Incident Report for Second Life
Resolved
This incident has been resolved, and stipends have been paid out.
Posted 16 days ago. Apr 02, 2019 - 11:10 PDT
Investigating
We are aware that some premium members did not receive their weekly stipend this morning, and we are currently working to get them processed as soon as possible. We appreciate your patience, and apologize for the delay! Please refer to this blog for updates.
Posted 16 days ago. Apr 02, 2019 - 07:31 PDT