Second Life Website Unscheduled Maintenance
Incident Report for Second Life
Resolved
Our investigating is complete. Second Life web pages should load as normal.
Posted 3 months ago. Aug 06, 2017 - 07:30 PDT
Investigating
We are investigating an issue with our Second Life websites. Residents may not be able to view some pages. Please keep an eye on this blog for updates.
Posted 3 months ago. Aug 06, 2017 - 06:58 PDT
This incident affected: Websites (secondlife.com) and Second Life Services (Process Credits).