Trouble Adding New Payment Methods - International Residents
Incident Report for Second Life
Resolved
This issue has been resolved and international Residents should be able to add new payment methods successfully to their accounts again. Please contact Support if additional issues are experienced.
Posted 30 days ago. Sep 18, 2018 - 19:13 PDT
Investigating
Our International resident's may experience issues adding a new payment method to their account. Any cards that have already been added should still be working at this time. We will update this post when the issue has been resolved.
Posted 30 days ago. Sep 18, 2018 - 13:56 PDT