Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance is complete.

Thank you for your patience.
Posted about 1 month ago. Apr 18, 2018 - 18:27 PDT
Investigating
We are currently performing unscheduled maintenance. While this maintenance is in progress, our billing services, including LindeX and Marketplace, may not be available. International Payments and adding Payment Methods may be affected.

Please check this blog for updates.
Posted about 1 month ago. Apr 18, 2018 - 15:19 PDT