Unscheduled Second Life Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been resolved.
Posted 3 months ago. Feb 27, 2018 - 06:11 PST
Investigating
We are aware that there may be intermittent issues with Second Life logins at this time. We are actively investigating the issue, and will provide updates via this blog. Please contact Support if you experience any difficulty with any purchases made during this time.
Posted 3 months ago. Feb 26, 2018 - 18:35 PST