Scheduled Maintenance for some Mainland regions
Incident Report for Second Life
Resolved
Scheduled maintenance has been completed. Thank you for your patience!
Posted about 1 month ago. Sep 15, 2017 - 16:16 PDT
Investigating
We are undergoing scheduled maintenance for some Mainland regions. During this time they may be unavailable. Please check this blog for updates.
Posted about 1 month ago. Sep 15, 2017 - 11:49 PDT