Concierge phone and Premium chat support unavailable
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted 24 days ago. Mar 30, 2018 - 13:10 PDT
Investigating
Concierge phone and Premium chat support is unavailable from 12:00 PM to 1:00 PM PDT, today March 30th, 2018. Case submissions are still available.
Posted 24 days ago. Mar 30, 2018 - 12:01 PDT