Unscheduled Live Chat Maintenance
Incident Report for Second Life
Resolved
Live Chat Maintenance has been completed/resolved.
Posted 16 days ago. Nov 30, 2017 - 17:27 PST
Update
We are continuing to investigate the trouble some Residents are having with Live Chat. If you are still having difficulty reaching live chat, go to this page (log in may be required): https://lindenlab.freshdesk.com/support/tickets/new

Once logged in, click the Need Help? button in the lower right corner of your browser window.
Posted 24 days ago. Nov 22, 2017 - 13:06 PST
Investigating
We are continuing to work on improvements to our Support Portal. At this time, Live Chat may be unavailable for some residents. Support Tickets, Billing phone and Concierge phone are still available. Please monitor this blog for updates.
Posted 25 days ago. Nov 21, 2017 - 07:59 PST
This incident affected: External Support (Chat Support).