Inworld Service Distruption
Incident Report for Second Life
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 15, 2017 - 17:56 PDT
Investigating
We are aware of some services in-world for some residents.
Posted about 1 month ago. Sep 15, 2017 - 16:38 PDT
This incident affected: Second Life Services (Logins) and Inworld Services (Voice Chat, Group Voice Chat).