Unscheduled Email-to-LSL Maintenance
Incident Report for Second Life
Resolved
The Unscheduled Email-to-LSL Maintenance has been completed.

Thank you for your patience.
Posted 21 days ago. Feb 03, 2018 - 16:57 PST
Investigating
We are currently investigating reports of issues with Second Life's Email-to-LSL feature. This feature is now currently undergoing unscheduled maintenance and we hope to have any issues resolved as quickly as possible. Additional information and updates will be provided here as they become available.
Posted 21 days ago. Feb 03, 2018 - 14:10 PST