Unscheduled Maintenance to my.secondlife
Incident Report for Second Life
Resolved
The unscheduled maintenance on my.secondlife.com and related services has been resolved. Thanks for your patience!
Posted 7 months ago. Dec 27, 2017 - 13:26 PST
Investigating
We are currently investigating an issue with my.secondlife regarding the inability to create new posts. Please watch this post for further updates. Your patience is appreciated.
Posted 7 months ago. Dec 27, 2017 - 12:40 PST
This incident affected: Websites (my.secondlife.com).