Unscheduled Concierge Phone Support Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been completed.
Posted May 20, 2018 - 05:48 PDT
Investigating
We are currently performing unscheduled maintenance to our Concierge phone support system. Live Chat and Support Ticket submission remains available. Please watch this page for further updates.
Posted May 19, 2018 - 12:14 PDT
This incident affected: External Support (Phone Support).