Support closed for Thanksgiving Holiday
Incident Report for Second Life
Resolved
Phone, Chat, and Ticket support is now available again. Please note that some users are still experiencing issues starting Live Chat - see this post for details: https://status.secondlifegrid.net/incidents/mj8y70n1rkfj
Posted 22 days ago. Nov 25, 2017 - 04:58 PST
Investigating
In observance of Thanksgiving - Basic, Premium and Concierge Live Chat and phone support will be closed. Case submissions will remain open. All support channels will re-open Saturday, November 25th at 5AM PDT
Posted 24 days ago. Nov 22, 2017 - 13:13 PST
This incident affected: External Support (Chat Support, Phone Support).