Unscheduled Billing Maintenance
Incident Report for Second Life
Resolved
The unscheduled maintenance has been resolved.
Posted 3 months ago. Sep 26, 2017 - 15:20 PDT
Investigating
We are performing unscheduled maintenance on our billing system. While this maintenance is in progress, credit card processing may be affected for some users. Please check this blog for updates.
Posted 3 months ago. Sep 26, 2017 - 15:09 PDT