Concierge Phone and Live Chat Unavailable
Scheduled for Jun 12, 12:45 - 15:00 PDT
Update
Phone and Live Chat support will be unavailable starting June 12th at 12:45 pm PST. Please note that we will still be accepting support tickets during this time. All Phone and Live Chat support will be available again June 13th at 6 am PST. We thank you for your understanding.
Posted 6 days ago. Jun 12, 2018 - 08:16 PDT
Scheduled
Concierge Phone and Live Chat support will be unavailable starting June 12th at 12:45 pm PST. Please note that we will still be accepting support tickets during this time. Concierge Phone and Live Chat support will be available again June 13th at 6 am PST. We thank you for your understanding.
Posted 6 days ago. Jun 12, 2018 - 06:48 PDT
This scheduled maintenance affects: External Support (Chat Support, Phone Support).