Possible Delay of Premium Stipends
Incident Report for Second Life
Resolved
The issue with delayed Premium Stipends has been resolved. We appreciate your patience.
Posted 20 days ago. Oct 03, 2017 - 10:39 PDT
Update
Thank you for your continued patience. We are working to resolve this issue now, and we will continue to provide updates as they become available.
Posted 20 days ago. Oct 03, 2017 - 07:31 PDT
Investigating
We are aware that some residents Weekly Premium Stipends may have been delayed, and we are currently investigating this issue. We will provide any updates regarding this issue via this blog. We apologize for any inconvenience that this may cause you. Thank you for your patience!
Posted 20 days ago. Oct 03, 2017 - 06:05 PDT
This incident affected: Inworld Services (L$ Transactions) and Second Life Services (LindeX Purchases).